Summary
How to resolve Miracast* connection issue.
Description
- Error message: "Couldn't connect," encountered when trying to connect to the Microsoft Miracast* display.
- Disconnected immediately after successfully connecting to the Microsoft Miracast display.
Resolution
Root cause:
The failure is caused by the C:\ProgramData\Microsoft\MF\Active.GRL file missing on the computer that updated the Windows version from an older version.
Options to resolve the issue:
- Restore C:\ProgramData\Microsoft\MF\Active.GRL from another computer where Miracast is working.
Or
- Clean install the latest Windows 10, refer to Install Windows from a USB Flash Drive.