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Customer Support 

For technical support, including answers to questions not addressed in this product, visit the technical support 

forum, FAQs, and other support information at:  

• https://software.intel.com/en-us/advisor/support/get-help  

• http://www.intel.com/software/products/support/  

• https://software.intel.com/en-us/advisor  

Please remember to register your product at https://registrationcenter.intel.com/ by providing your email 

address. Registration entitles you to free technical support, product updates and upgrades for the duration of 

the support term. It also helps Intel recognize you as a valued customer in the support forum. 

NOTE: If your distributor provides technical support for this product, please contact them for support rather 

than Intel. 
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1 Introduction 
Intel® Advisor 2019 Update 5provides two tools to help ensure your Fortran, C and C++ (as well as .NET on 

Windows*) applications take full performance advantage of today's processors: 

• Vectorization Advisor is a vectorization analysis tool that lets you identify loops that will benefit most 

from vectorization, identify what is blocking effective vectorization, explore the benefit of alternative 

data reorganizations, and increase the confidence that vectorization is safe. 

• Threading Advisor is a threading design and prototyping tool that lets you analyze, design, tune, and 

check threading design options without disrupting your normal development. 

This document provides system requirements, issues and limitations, and legal information. 

To learn more about this product, see: 

• New features listed in the What’s New section below. 

• The help document at https://software.intel.com/en-us/advisor-user-guide   

https://software.intel.com/en-us/advisor/support/get-help
http://www.intel.com/software/products/support/
https://software.intel.com/en-us/advisor
https://registrationcenter.intel.com/
https://software.intel.com/en-us/advisor-user-guide
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2 What’s New 

Intel® Advisor 2019 Update 5 

• Intel Advisor has been updated to include more recent versions of 3rd party components, which include 

functional and security updates. Users should update to the latest version.  

• Roofline Guidance in Code Analytics. This feature is intended to make the Roofline chart easier to 

understand and use.   

• Integration support for Visual Studio 2019 Update 1. 

• Improved Roofline configuration menu for easier chart customization.  

• Updated command line help content. 

Intel® Advisor 2019 Update 4 

• Removed requirement for flock operation in file systems. Previously Advisor failed when flock was 

disabled, requiring projects to be kept locally. It should now run smoothly on file systems like Lustre*. 

• Added per-loop and per-application recommendations to the Summary pane. This replaces and 

expands on the "top 5 recommendations" section which was removed in the previous update. 

• Survey and Code Analytics now support and identify which loops/functions use CLX VNNI instructions, 

which are often used in neural network applications. 

• Column configurator has been extended to the Top-Down pane. Previously this customization feature 

was limited to the Survey pane. 

• FLOPS and Trip Counts collections now extend existing data rather than replacing it. For example, if 

Trip Counts are collected, and then a second analysis is run to collect FLOPS only, the FLOPS data will 

be added to the result without removing the Trip Counts.  

• New Preview Feature: Roofline Guidance in Code Analytics. This feature is intended to make the 

Roofline chart easier to understand and use. Enable by setting the environment variable 

ADVIXE_EXPERIMENTAL=roofline_guidance 

• Support for Microsoft* Visual Studio* 2019 added. 

• Flow Graph Analyzer: 

o Support for Red Hat Enterprise Linux* 7 restored. 

o Bug fix to restore graph properties after interaction with hierarchical view. 

o Added support for the use of edges across graphs. This use case is restricted by default, but 

can be enabled from the Preferences dialogue. 

Intel® Advisor 2019 Update 3 

• Improved Summary pane with a sleeker look and better program-level issue highlighting, including a 

new block with memory bandwidth information. 

• Survey columns can now be customized using the column configurator. Configurations can be saved 

for later use. 

• Сache Simulator configuration dialog allows visual configuration of different cache levels for Memory 

Access Patterns analysis. 

• Simplified installation and licensing (serial numbers and license files are no longer required for this 

product). 

• Roofline improvements: 
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o Improved Roofline comparison feature visually distinguishes the compared result sets. Advisor 

automatically maps corresponding dots from compared results to each other with arrows and 

displays FLOPS delta. Filtering the roofline also takes compared results into account. 

o Roof values can be adjusted to the number of sockets used on the system to achieve more 

accurate performance ceilings for applications using thread pinning (such as MPI applications 

pinning ranks to sockets). 

o You can now export roofline snapshots in SVG format for high-quality pictures. 

o Added zone highlighting to the Roofline to visually indicate what types of bottleneck apply to 

dots based on position. 

o Added automatic smart roof selection that highlights relevant roofs based on the types of 

instruction present. 

• Flow Graph Analyzer improvements: 

o Flow Graph Analyzer can be launched from Advisor GUI on Windows and Linux. 

o Can now display execution traces on CPU/core swimlanes in the timeline charts. 

o Can now select different layout schemes for the tree-map view with the squarified layout being 

the default. 

o Tree-map display performance improved by caching the computation in the metaxml file. 

o Scalability analysis now abridges long-running computations. Users have control over how 

much they want a computation abridged. 

o Support for TBB’s lightweight policy added to scalability analysis. 

• Support for Fedora* 29 added. 

Intel® Advisor 2019 Update 2 

• Intel® Advisor 2019 Update 2 includes functional and security updates. Users should update to the 

latest version. 

Intel® Advisor 2019 Update 1 

• Ability to switch between “all integer operations” and “pure compute integer operations” in the Survey 

Grid column settings 

• Ability to export Integer and INT+FLOAT operations Roofline html report via command line interface 

• Detecting usage of VNNI instructions in Traits column 

• Introduced 64-bit Graphical User Interface on Windows*, that allows working with huge results 

• Added “expand sub-tree” context menu option to Top-down tree, simplifying exploring long call chains 

• Decreased overheads for Trip Counts, FLOPS and Roofline analyses with stacks collection 

• Integrated Roofline (Preview): 

o Ability to select mode of memory-related metrics by cache level and memory operations type 

(Loads, Stores, both operations) in the Survey Grid column settings 

o Ability to export Roofline html report for different memory levels and operation types via 

command line interface 

• Recommendations enhancements: 

o Added recommendation for Reciprocal instruction in AVX512 

o Added recommendation to enable code alignment with #pragma code_align for efficient use 

of L1 instruction cache 

o Added recommendation on vector length overriding in ICC 2019 
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o Updated recommendation "Use the Fortran 2008 CONTIGUOUS attribute" by adding new 

compiler options 

• New OS support: 

o Red Hat* Enterprise Linux* 6.10 

o Ubuntu* 18.10 

Intel® Advisor 2019  

• Optimize integer calculations using Integer roofline analysis 

• Preview feature: Integrated Roofline showing which exact memory layer is the bottleneck for each loop. 

To enable this functionality set the environment variable ADVIXE_EXPERIMENTAL=int_roofline. 

• macOS* user interface to view and analyze data collected on Linux* or Windows* 

• Get a more accurate memory footprint and check multiple hardware configurations with cache 

simulation 

• Productively prototype graph algorithms with Flow Graph Analyzer. 

• Reduce overhead for faster analysis results using selective profiling 

o Decreasing overhead for Memory Access Patterns and Dependencies analyses via limiting loop 

call count and analysis duration in project properties. 

o Selective profiling for Roofline, FLOPS and Trip Counts collections to decrease analysis scope 

and decrease overhead 

• Roofline enhancements: 

o Share results with colleagues by exporting a dynamic HTML copy of the roofline analysis. 

o "Filter-in" arbitrary subset of dots on Roofline chart for simplifying complex charts analysis and 

saving only selected dots to bitmaps. 

o Ability to adjust the Roofline to a custom number of threads to see the practical performance 

limits for a given application. 

o Roofline benchmarks are now synchronized for multi-rank MPI applications, so that the roof 

values will be the same on all ranks running on the same physical node. 

o Ability to compare several roofline results on the same chart 

• Recommendations: 

o New recommendation to optimize standard algorithms in C++ with Parallel STL. 

o User code specific parameters for recommendations, such as certain value of suggested unroll 

factor or function name to be inlined. 

o Recommendation to use non-temporal store (NTS) instructions to improve memory bound 

application performance. 

• Usability improvements: 

o Font size can be now customized in Options menu. This may help to adjust GUI appearance in 

SSH X-forwarding sessions. 

o Ability to select loops in command line by source file and line: advixe-cl --mark-up-loops 

--select main.cpp:12,other.cpp:198 

• New OS support 

o Fedora* 28 

o Red Hat* Enterprise Linux* 7.5 

o Microsoft* Windows* 10 build 17134 

o Ubuntu* 18.04 

o SUSE* Linux Enterprise Server* 12 SP3 
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o SUSE* Linux Enterprise Server* 15 

o macOS* 10.11.x, 10.12.x and 10.13.x 

3 System Requirements 

Supported Architectures and Terminology 

Intel® Advisor supports the following architectures: 

• IA-32 Architecture refers to systems based on 32-bit processors generally compatible with the Intel 

Pentium® processors (for example, Intel® Pentium® 4 processor or Intel® Xeon® processor), or 

processors from other manufacturers supporting the same instruction set, running a 32-bit operating 

system. 

• Intel® 64 Architecture refers to systems based on IA-32 architecture processors which have 64-bit 

architectural extensions, for example, Intel® Core™ architecture processors, running a 64-bit operating 

system such as Microsoft Windows 8* x64 or a Linux* "x86_64" variant. If the system is running a 32-bit 

operating system, then IA-32 architecture applies instead. 

Hardware Requirements 

• At least 2 GB of RAM 

• 650 MB free disk space required for all product features and all architectures. 

• A system based on an IA-32 or Intel® 64 architecture processor supporting the Intel® Streaming SIMD 

Extensions 2 (Intel® SSE2) instructions (Intel® Pentium 4 processor or later, or compatible non-Intel 

processor or Intel® Xeon® Scalable Processors) 

o Since the Intel® Advisor requires specific knowledge of assembly-level instructions, its analysis 

may not operate correctly if code contains non-Intel instructions. In this case, run the analysis 

with a target executable that contains only Intel® instructions. After you finish using the Intel® 

Advisor, you can use the assembler or optimizing compiler options that provide the non-Intel 

instructions. 

o For the best experience, a multi-core or multi-processor system is recommended 

Software Requirements 

NOTE: On Linux*, the X.Org X11 libXss runtime library must be installed for the Intel® Advisor GUI. 

• Supported operating systems: 

o Microsoft Windows* 8.1 operating system 

o Microsoft Windows* Server 2012, 2012 R2 and 2016 

o Microsoft Windows* 10 operating system (up to build 1809)  

o Red Hat* Enterprise Linux* 7 (including 7.5)  

o CentOS* versions equivalent to Red Hat* Enterprise Linux* versions listed above 

o Fedora* 27, 28, and 29 (pangox-compat package should be installed)  

o SUSE* Linux Enterprise Server* 11, 12 (up to SP3) and 15 

o Debian* 8 and 9 

o Ubuntu* 16.04, 18.04, and 18.10 

o Viewer only: macOS* 10.13 and 10.14 
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NOTE: The following operating systems are not supported by Flow Graph Analyzer: SUSE* Linux 

Enterprise Server* 11, Debian* 8, and Fedora* 27. 

NOTE: Support for the following operating systems will be removed in a future release: Microsoft* 

Windows* Server 2012, Fedora* 27 and 28, SUSE* Linux Enterprise Server 11, Debian* 8, and 

macOS* 10.13. 

• Supported Microsoft* Visual Studio* (and Microsoft Visual C++* compiler) versions:  

o Microsoft Visual Studio* 2013  

o Microsoft Visual Studio* 2015  

o Microsoft Visual Studio* 2017 

o Microsoft Visual Studio* 2019 

NOTE: Support for Microsoft* Visual Studio* 2013 and 2015 will be removed in a future release. 

• Supported compilers:  

o Intel® C++ Compiler 15 or higher 

o GNU* C/C++ Compiler 3.4.6 and higher (Linux*) 

o Intel® Fortran Compiler 15 or higher (Linux*) 

o Intel® Visual Fortran Compiler 15 or higher (Windows*) 

• Application coding requirements 

o Supported programming languages:  

▪ Fortran 

▪ C 

▪ C++ 

o Supported threading methodologies:  

▪ Intel® Threading Building Blocks (Intel® TBB)  

▪ Intel® Cilk™ Plus 

▪ OpenMP* 

▪ Windows* and POSIX Threads (low-level)  

• Managed application coding requirements 

o Supported programming languages:  

▪ C# (.NET* versions 3.0 to 4.0)  

o Supported threading methodologies 

▪ C# Thread Class 

▪ Microsoft* Task Parallel Library (TPL) 

• To view PDF documents, use a PDF reader, such as Adobe Reader*. 

• To enable automatic product updates with the Intel® Software Update Manager, use Java* version 1.6 

or higher. 

NOTE: Intel® Advisor samples work with the Intel® Threading Building Blocks (Intel® TBB) by using the 

environment variable TBBROOT. Intel® TBB is included with the Intel® compiler and is available from 

http://software.intel.com/en-us/intel-tbb/ . To build the Intel® TBB projects, you will need to define the TBBROOT 

environment variable. To set the TBBROOT environment variable, see the Intel® Advisor Help or Getting 

Started Tutorial. 

http://software.intel.com/en-us/intel-tbb/
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4 Where to Find the Release 
If you have a qualifying license for this product (i.e. an unexpired free license or a paid license with active 

support at the time of the build date for this product release), you can download the installer by logging in to 

https://registrationcenter.intel.com/ and selecting the appropriate product.  

You may need to create an account and/or register your product. For additional information please see:  

• https://software.intel.com/en-us/faq/registration 

• https://software.intel.com/en-us/faq/downloading  

5 Installation Notes 
Installation of Intel® Advisor removes any earlier minor versions of the product within the same major version 

that are installed on the system. Different major versions can co-exist with each other; however, on Windows*, 

only one version can be integrated with a particular version of Microsoft* Visual Studio* at once. 

On Windows*, double-click on the compressed self-extracting executable file as a user with administrative 

privileges to begin installation. Select the full installation option to use default install settings and get the 

complete set of user interfaces (which includes a GUI front-end for using the product as well as Microsoft* 

Visual Studio* integration). To learn details of silent non-interactive installation on Windows* systems, refer to 

http://software.intel.com/en-us/windows_silent_installation_guide . 

On Linux*, perform the following steps: 

1. Uncompress the package:  

gunzip <package-name>.tar.gz 

2. Extract the files:  

tar xf <package-name>.tar 

3. Make sure you have read and write permissions for the /tmp directory and start the installation. To 

install on a local system enter the following: 

cd <package-name> 

./install.sh 

NOTE: If you want to install the software for use by any user, you must do this as the root user. To 

install to a network-mounted drive or shared file system for multiple users, enter (as root user): 

cd <package-name> 

./install.sh --SHARED_INSTALL 

4. Follow the prompts to complete the installation of the software. 

Intel® Software Manager  

Intel® Software Manager installs with Intel Software Development Products on Windows* operating systems. 

Intel Software Manager is a utility that lets you: 

• Download and install updates for your Intel® Software Development Products.  

• Manage subscription status of installed software.  

• Activate serial numbers.  

https://registrationcenter.intel.com/
https://software.intel.com/en-us/faq/registration
https://software.intel.com/en-us/faq/downloading
http://software.intel.com/en-us/windows_silent_installation_guide
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• Find out about the latest news for Intel Software Development Products.  

Intel Software Manager requires an Internet connection to connect to a remote server for information and 

updates.  

For more information about the Intel Software Manager, see https://registrationcenter-

ssl.intel.com/Docs/ism.htm . 

Default Installation Folders 

The default top-level installation folders for this product are: 

• Windows: C:\Program Files\IntelSWTools\Advisor 2019 

o If you are installing on a system with a non-English language version of Windows* OS, the 

name of the Program Files folder may be different. On Intel® 64 systems, the directory 

name is Program Files (x86) or the equivalent. 

• Linux: /opt/intel/advisor_2019 

In both cases, there is also a generic soft link to the most recently installed version. 

Changing, Updating and Removing the Product 

On Windows*, if you want to modify, repair, or remove the Intel® Advisor components, open the Control Panel 

and select the Add or Remove Programs applet (or Programs and Features in Microsoft Windows 7), select 

Intel Advisor 2019 and click Change/Remove (or Uninstall/Change in Microsoft Windows 7). Follow the 

installation instructions. You may need the original installation files to complete this process. If you do not have 

the extracted files, you can use the original installer executable to complete this process as well. 

On Linux*, to remove the product, execute the following commands as a root user or the same user who 

performed the installation: 

1. cd <installation_dir>  

2. uninstall.sh  

Known Installation and Configuration Issues 

On Windows*, please close Microsoft* Visual Studio* sessions before installing, modifying, or removing the 

Intel® Advisor. Not doing so will affect Visual Studio integration and may result in obscure error messages. 

Setting Up the Command Line 

Before using Intel® Advisor on the command line, you will need to set up the environment: 

• Windows: <installation_dir>\advixe-vars.bat 

• Linux: source <installation_dir>/advixe-vars.sh 

NOTE: To build the Intel® Advisor sample applications, you may need to first define the 

ADVISOR_2019_DIR environment variable. Running the advixe-vars.sh script will do this 

automatically. 

https://registrationcenter-ssl.intel.com/Docs/ism.htm
https://registrationcenter-ssl.intel.com/Docs/ism.htm
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6 Known Issues 
This section is quite long. To skip to operating system specific limitations, use these links: 

• Windows* Specific Limitations 

• Linux* Specific Limitations 

Common Limitations 

SUITABILITY TOOL MAY NOT ACCURATELY MEASURE VERY SHORT LOOPS 

The Suitability tool cannot accurately measure and analyze the behavior of loops with very small task times (on 

the order of sub-microseconds) if those tasks are annotated with the TASK_BEGIN/TASK_END annotations. If 

possible, use the ITERATION_TASK annotation instead. 

SUITABILITY REPORT COMBINES LOCK DATA 

The Suitability Report combines all lock data into a single lock and may not have source line information for 

LOCK_ACQUIRE and LOCK_RELEASE annotations. 

HUGE SOURCE FILES MAY NOT BE COMPLETELY PARSED FOR ANNOTATIONS 

If your sources include huge source files that contain annotations, be aware that only the first 8 MB of each file 

will be parsed for annotations. If not all of your annotations are being parsed in such huge source files, 

consider breaking that source file into several source files each less than 8MB. 

NON-RETURNING FUNCTIONS MAY CAUSE INCORRECT LOOP REPORTS 

The Survey Report may incorrectly report loops if a function contains calls to a non-returning function such as 

the exit() function. 

LOOPS IN FUNCTIONS WITHOUT DEBUG INFORMATION MAY NOT BE RECOGNIZED AS LOOPS 

Loops within a function that does not contain debug information may not be reported as a loop in the Survey 

Report. For the suggested build settings, see the help topics under Choosing and Building a Target > Build 

Settings for C/C++ Applications or Build Settings for Fortran Applications. After you fix the build settings 

to specify debug information, rebuild the target and run Survey analysis again. 

SURVEY MAY REPORT NO SIGNIFICANT HOTSPOTS 

After analyzing the specified target executable, the Survey tool may report that no significant hotspot areas 

were detected. In this case, view the collected result using the Survey Report window. The suggested build 

settings are described in the help topics under Choosing and Building a Target > Build Settings for C/C++ 

Applications or Build Settings for Fortran Applications. 

INTEL® ADVISOR MAY FAIL TO CORRELATE DATA WITH SOURCE CODE 

If debug information correlating an instruction to source code is not available to an Intel® Advisor tool, the tool 

cannot correlate collected data with source code. In this case it will show an empty field, question mark, or 

broken icon. Source correlation may not be available for many different reasons, including: 

• Omitting debug information options when building the target executable - see the help topics under 

Choosing and Building a Target > Build Settings for C/C++ Applications or Build Settings for 

Fortran Applications. 

• A compiler error. 
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• The compiler not generating debug information for this specific source line or source file. 

• The linker not copying the debug information into the debug information database. 

• The debug information database not being found by the finalization step in the Intel® Advisor, because 

it was not moved along with the executable to the location where the Intel® Advisor is being run. 

• When using the Intel® Advisor GUI, insufficient project properties were specified for the Binary/Symbol 

Search tab. See https://software.intel.com/en-us/advisor-user-guide-binary-symbol-search-tab . 

Windows* Specific Limitations 

ADVISOR MAY NOT MANUALLY INTEGRATE INTO MICROSOFT* VISUAL STUDIO* 2017 

Intel® Advisor integrates into Microsoft Visual Studio 2017 only using the official Intel Advisor installation. Any 

other ways like advixe-vsreg.exe tool or manual launching .vsix package will not work. 

ADVISOR MAY HANG IF GUI OR MICROSOFT* VISUAL STUDIO* IS CLOSED WHILE EXPANDING A SURVEY TREE 

Do not close the Intel® Advisor GUI or Microsoft Visual Studio* software while expanding the Survey tree. 

Doing so may cause the product to crash or hang. 

ADVISOR MAY REPORT INCORRECT DATA IF LOCAL CHARACTER SETS ARE USED 

Intel® Advisor may present incorrect or incomplete information if local character sets are used. For general 

character set support, use Unicode. 

WINDOWS SERVER* 2012 SYSTEMS MAY NOT CORRECTLY DISPLAY MICROSOFT* VISUAL STUDIO* 2012 HELP PAGES 

On Windows Server 2012 systems, if you have problems viewing Microsoft Visual Studio* 2012 help pages, 

check the settings for Internet Explorer* in Tools > Internet Options > Security. To allow correct display of 

help, in the Internet zone enable MIME Sniffing and Active scripting. 

WINDOWS SERVER* 2012 SYSTEMS MAY NOT CORRECTLY DISPLAY GETTING STARTED TUTORIALS IN INTERNET 

EXPLORER* 10 

On Windows Server 2012 systems, if you find that you cannot display Getting Started Tutorials from within 

Internet Explorer 10, correcting a security setting for Microsoft Internet Explorer usually corrects the problem. 

From Tools > Internet Options > Security , add "about:internet" to the list of trusted sites. Optionally, you can 

remove "about:internet" from the list of trusted sites after you are finished viewing the documentation. 

ADVISOR MAY INCORRECTLY DISPLAY "PROJECT IS OUT OF DATE" 

Intel® Advisor may display a message that the "Project is out of date" before running the data collectors. You 

do not need to rebuild the project prior to running the collector if you know that the project is up-to-date. 

MICROSOFT* VISUAL STUDIO* MAY DISPLAY A WARNING MESSAGE WHEN OPENING ADVISOR SAMPLES 

When opening the Intel® Advisor samples, Microsoft Visual Studio* software will display a warning message 

related to Intel® Cilk Plus projects or list them as unsupported when the Intel® C++ Compiler is not installed. 

This message may be ignored. However, Intel® Cilk Plus projects will not compile without an Intel® C++ 

Compiler with Intel® Cilk Plus support, such as the Intel® Parallel Studio XE (or similar Intel® software suite). 

ANTIVIRUS SOFTWARE MAY PREVENT ADVISOR FROM INSTRUMENTING CODE 

Virus checking can sometimes interfere with our ability to instrument code. Currently there is no workaround, 

except turning off the virus checker.  

https://software.intel.com/en-us/advisor-user-guide-binary-symbol-search-tab
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Linux* Specific Limitations 

TARGET APPLICATION OUTPUT MAY NOT DISPLAY WHEN BEING ANALYZED FROM THE ADVISOR GUI 

When the Intel® Advisor GUI is launched from a Linux OS desktop GUI (such as the KDE* or GNOME* GUI) 

the output of the non-GUI target application being analyzed will not be displayed. To avoid this, launch the 

Intel® Advisor GUI from a command shell with the advixe-gui command instead of the desktop GUI, or 

redirect the non-GUI application output to the Intel® Advisor output window by choosing File > Options > 

Application output destination > Application output window. 

ADVISOR HELP MAY NOT WORK IN SOME BROWSERS 

If you encounter problems searching the Intel® Advisor help using a certain web browser, consider using a 

newer version of that browser or use a different web browser as your default browser. 

ADVISOR MAY DETECT TIMER SOURCE INCORRECTLY ON SOME PROCESSORS 

Intel® Advisor may detect which timer source to use incorrectly on extreme desktop SNB-E (e.g. Intel® Core 

i7-3960X) processors. In Survey and Suitability collections the following message may be displayed in the 

command line or Debug Window: 

Warning: Cannot load data file `/tmp/linux/openmp_triad/r007hs/data.0/25448-25455.0.trace' (Data file is 

corrupted). 

To work around the problem, collect results from the command line using "-run-pass-thru" option:  

advixe-cl -collect survey -run-pass-thru=-timestamp=sys -- <application> 

RUNNING ADVISOR GUI IN BACKGROUND MODE AND ANALYZING AN APPLICATION THAT TAKES CONSOLE INPUT MAY 

APPEAR TO CAUSE A HANG 

Running Intel® Advisor in the linux console in background mode (./advixe-gui &) and profiling an 

application that uses input from the console (stdin) cause a product stop by the operating system that looks like 

a product hang. To avoid this problem, either run your application with input from a file specified in application 

arguments or do not use background mode. 

HELP OR RECOMMENDATIONS HTML FILES MAY NOT WORK WITHOUT XDM-UTILS PACKAGE 

Opening links to HTML files, such as help or recommendations, is not guaranteed if the xdm-utils package 

is not installed. Possible solutions are: 

• Install the xdm-utils package. 

• Use the default terminal program for KDE or Gnome desktop environments. 

ADVISOR MAY NOT WORK UNDER SECURITY-ENHANCED LINUX* (SELINUX) SETTINGS 

Security-enhanced Linux* settings (SELinux) are currently not supported by the Intel® Advisor and need to be 

either disabled or set to permissive for a successful tool suite installation. This product supports only 

"Permissive" mode. To run the product successfully you may either disable SELinux by  

• setting the line "SELINUX=disabled" in your /etc/sysconfig/selinux file  

• adding "selinux=0" kernel argument in lilo.conf or grub.conf files  

or make a SELinux mode adjustment by  
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• setting the line "SELINUX=permissive" in your /etc/sysconfig/selinux file  

• ask your system administrator to make a SELinux mode adjustment 

You may need to reboot your system after changing the system parameters. More information about SELinux 

can be found at http://www.nsa.gov/research/selinux/index.shtml . 

CONTENTS TAB OF ADVISOR DOCUMENTATION MAY APPEAR TRUNCATED IN CERTAIN BROWSERS 

When using certain HTML browsers to view the Intel® Advisor documentation, if the Contents tab width 

appears truncated and hides some of the topic titles: 

• Click the Index (or Search) button 

• Click the Contents button 

7 Attributions 
The license information for third party software that was used to develop Intel® Advisor can be found in 

<install_dir>/documentation/en/third-party-programs.txt . 

For the avoidance of doubt, the Intel® Advisor is solely governed by the terms and conditions of the End User 

License Agreement for Intel® Software Development Product that accompanies the Intel® Advisor. 

8 Legal Information 
No license (express or implied, by estoppel or otherwise) to any intellectual property rights is granted by this 

document. 

Intel disclaims all express and implied warranties, including without limitation, the implied warranties of 

merchantability, fitness for a particular purpose, and non-infringement, as well as any warranty arising from 

course of performance, course of dealing, or usage in trade. 

This document contains information on products, services and/or processes in development. All information 

provided here is subject to change without notice. Contact your Intel representative to obtain the latest 

forecast, schedule, specifications and roadmaps. 

The products and services described may contain defects or errors which may cause deviations from 

published specifications. Current characterized errata are available on request. 

Intel, the Intel logo, Intel Core, and Xeon are trademarks of Intel Corporation in the U.S. and/or other countries.  

*Other names and brands may be claimed as the property of others. 

Microsoft, Windows, and the Windows logo are trademarks, or registered trademarks of Microsoft Corporation 

in the United States and/or other countries. 

Java is a registered trademark of Oracle and/or its affiliates. 

Copyright 2010 - 2019 Intel Corporation. 

http://www.nsa.gov/research/selinux/index.shtml
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This software and the related documents are Intel copyrighted materials, and your use of them is governed by 

the express license under which they were provided to you (License). Unless the License provides otherwise, 

you may not use, modify, copy, publish, distribute, disclose or transmit this software or the related documents 

without Intel's prior written permission. 

This software and the related documents are provided as is, with no express or implied warranties, other than 

those that are expressly stated in the License. 


